Hope you’re issue is resolved by now, if not then I have a solution for you. Don’t use OData feed, instead create a web template fetch in liquid and add created on filter on or before now. using this fetch generate a JSON via liquid, create a web page with some partial URL and use this web template. Don’t forget to exclude the header and footer. you’ll get your real-time response. The key here is to add a variable parameter in fetch which brings fresh results every time rather than cached results.